Unplanned service interruption: Library Catalogue
Incident Report for University of South Australia
Resolved
The vendor has resolved the issue
Posted Dec 20, 2021 - 17:22 ACDT
Investigating
The Library Catalogue is currently experiencing issues. The vendor is currently investigating
Posted Dec 20, 2021 - 16:22 ACDT
This incident affected: Enabling Systems (Library Catalogue).