Unplanned Service Interruption: Microsoft Power Apps and Power Automate
Incident Report for University of South Australia
Resolved
Microsoft have resolved this issue overnight after rolling-back a change.
Posted Nov 17, 2023 - 08:32 ACDT
Investigating
We are currently investigating this issue and have raised a case with Microsoft.

Services Affected: Microsoft Power Apps, Power Automate and possibly other Power Platform cloud services.

Impact of Interruptions: Apps and flows may be unable to connect to other services, including SharePoint. Error messages may appear.

Contact: IT Help Desk, ITHelpdesk@unisa.edu.au, +61 8 830 25000
Posted Nov 16, 2023 - 15:54 ACDT
This incident affected: Enabling Systems (SharePoint Online (Office 365)).