UniSA Qualtics Survey interface is unavailable

Incident Report for University of South Australia

Resolved

This incident has been resolved.
Posted Jan 05, 2026 - 10:21 ACDT

Investigating

Surveys can still be completed by staff/students/public as needed but the admin interface to change or download content is unavailable
Posted Dec 31, 2025 - 10:51 ACDT