AU Box cloud storage is unavailable

Incident Report for University of South Australia

Resolved

This incident has been resolved by the vendor
Posted Dec 17, 2025 - 15:42 ACDT

Identified

The vendor is having issues throughout Australia and are working through a fix. For more info please see the box status page - https://status.box.com/incidents/48t1p9xtd4tz
Posted Dec 17, 2025 - 13:37 ACDT