Unplanned service interruption: UniSA Media Library
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 10 days ago. Sep 13, 2019 - 22:28 ACST
Investigating
The UniSA Media Library is currently experiencing technical issues, but a team of people are investigating.

Further updates will be posted shortly.
Posted 10 days ago. Sep 13, 2019 - 21:49 ACST
This incident affected: Learning and Teaching (Media Library).