Skype for Business having an intermittent issues.
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 14, 2019 - 17:46 ACDT
Investigating
We are currently investigating this issue.
Posted 7 months ago. Jan 14, 2019 - 17:31 ACDT