Library Catalogue
Incident Report for University of South Australia
Resolved
Our third party provider has advised the service interruption has been resolved.
Posted Jan 02, 2022 - 18:25 ACDT
Investigating
Our third party provider is currently investigating the service interruption.
Posted Jan 02, 2022 - 17:53 ACDT
This incident affected: Enabling Systems (Library Catalogue).