Delayed Turnitin Processing - learnonline (Moodle)
Incident Report for University of South Australia
Resolved
The Turnitin queue has now been cleared.
Posted Jun 18, 2021 - 09:54 ACST
Investigating
There are delays in the processing of student assignments through Turnitin. The issue may result in Turnitin results being delayed up to 48 hours.

Apologies on this issue.
Posted Jun 17, 2021 - 10:02 ACST
This incident affected: Learning and Teaching (learnonline (Moodle)).