Mawson Lakes Library Closed - 3rd July 2018
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 13 days ago. Jul 04, 2018 - 05:13 ACST
Update
We are continuing to work on a fix for this issue.
Posted 13 days ago. Jul 03, 2018 - 18:47 ACST
Identified
Mawson Lakes Library will not be open until 4th of July 2018 due to a power outage
Posted 13 days ago. Jul 03, 2018 - 18:45 ACST
This incident affected: Library Website.