Scheduled Maintenance: EmpowerHR and myHR-Employee Self Service ESS
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 12, 2018 - 20:31 ACST
Identified
EmpowerHR and myHR-Employee Self Service ESS will be unavailable during the following maintenance window from 5:00 pm to 8:30 pm Thursday 12th of July.
Posted 2 months ago. Jul 12, 2018 - 17:00 ACST