Mawson Lakes Campus Library closed 14th of July
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted Jul 16, 2018 - 08:51 ACST
Update
We are continuing to work on a fix for this issue.
Posted Jul 13, 2018 - 16:52 ACST
Identified
Mawson Lakes campus library will be closed on Saturday the 14th July. We will reopen at 7:00am on Sunday the 15th July.
Posted Jul 13, 2018 - 16:44 ACST
This incident affected: Enabling Systems (Library Website).