EMPOWRHR Upgrade
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted about 2 months ago. Nov 30, 2018 - 21:01 ACDT
Investigating
EmpowerHR will be unavailable from 5:05PM Friday 30th November 2018 until 9PM Friday 30th November 2018 to facilitate a planned upgrade. Thank you for your patience.
Posted about 2 months ago. Nov 30, 2018 - 17:00 ACDT