Student Follow U Queue Printing - ALL CAMPUSES
Incident Report for University of South Australia
Resolved
Follow You Printing was fully restored a few minutes ago. City and suburban campuses confirmed.
Root cause to be investigate with SI
Posted 3 months ago. Sep 04, 2017 - 10:00 ACST
Investigating
We are currently experiencing follow u queue printing issues across all campuses affecting all student printing, the root cause is currently being investigated and at present there is no ETA.
Posted 3 months ago. Sep 04, 2017 - 09:14 ACST