Unplanned service interruption: UniSA Media Library
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 05, 2019 - 21:50 ACST
Investigating
The UniSA Media Library is currently experiencing technical issues, but a team of people are investigating.

Further updates will be posted shortly.
Posted 18 days ago. Sep 05, 2019 - 20:17 ACST
This incident affected: Learning and Teaching (Media Library).