Scheduled Maintenance: EmpowerHR and myHR-Employee Self Service ESS
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted about 2 months ago. Aug 09, 2019 - 20:17 ACST
Update
We are continuing to work on a fix for this issue.
Posted about 2 months ago. Aug 09, 2019 - 16:47 ACST
Identified
EmpowerHR and myHR-Employee Self Service ESS will be unavailable during the following maintenance window from 5:00 pm to 8:30 pm Friday 9th of August.
Posted about 2 months ago. Aug 09, 2019 - 16:47 ACST