myEnrolment - Unplanned Maintenance In Progress
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted Nov 18, 2019 - 13:46 ACDT
Investigating
We are currently investigating the issues at this time, currently there is no ETA available
Posted Nov 18, 2019 - 11:52 ACDT
This incident affected: Student Lifecycle (myEnrolment).