EmpowerHR is currently unavailable
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 07, 2018 - 06:13 ACDT
Investigating
A problem currently exists with EmpowerHR and is being investigated by ISTS.
Posted about 1 month ago. Dec 06, 2018 - 15:07 ACDT