Student Follow U Queue Printing - ALL CAMPUSES
Incident Report for University of South Australia
Resolved
The issue has been investigated and is now resolved, testing completed and restoration of student printing is confirmed.
Posted 3 months ago. Sep 01, 2017 - 09:50 ACST
Investigating
We are currently experiencing follow u queue printing issues across all campuses affecting all student printing, the root cause is currently being investigated and at present there is no ETA.
Posted 3 months ago. Sep 01, 2017 - 09:06 ACST