Sharepoint 2007 Team sites is down
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 15 days ago. Jul 02, 2018 - 15:22 ACST
Investigating
CIS is currently investigating the issue
Posted 15 days ago. Jul 02, 2018 - 12:50 ACST