Ask the Library Outage
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 03, 2018 - 18:30 ACST
Monitoring
Ask the Library services are currently unavailable due to a power outage in Mawson Lakes
Posted 4 months ago. Jul 03, 2018 - 18:24 ACST
This incident affected: Library Website.