Mawson Lakes Library closing 6pm Friday July 6 and reopening 7am Monday July 9
Incident Report for University of South Australia
Resolved
This incident has been resolved.
Posted 2 months ago. Jul 10, 2018 - 12:06 ACST
Monitoring
UPDATE: The Sir Eric Neal Library at Mawson Lakes Campus will close at 6pm, Monday July 9, due to works on the Electricity Network. We will open again at 7am on Tuesday July 10.
Posted 3 months ago. Jul 06, 2018 - 09:31 ACST
This incident affected: Library Website.